Changes between Version 22 and Version 23 of FAQ


Ignore:
Timestamp:
04/26/13 11:13:25 (7 years ago)
Author:
schueller
Comment:

updated rot install

Legend:

Unmodified
Added
Removed
Modified
  • FAQ

    v22 v23  
    1818 
    1919==== Failures during the 'make check' stage ==== 
    20 You probably forgot to install '''rotRPackage''' as described in the [wiki:HowToInstall] page. For example, for OpenTURNS v0.15, the rotRPackage_1.4.4.tar.gz file is located in the "utils" directory of openturns-0.15.tar.gz.  
     20You probably forgot to install '''rot''' as described in the [wiki:HowToInstall] page. For example, for OpenTURNS 1.1, the rot_1.4.5.tar.gz file is located in the "utils" directory of openturns-1.1.tar.gz.  
    2121 
    2222Install it with the statement: 
    2323{{{ 
    24 R CMD INSTALL utils/rotRPackage_1.4.3.tar.gz 
     24R CMD INSTALL utils/rot_1.4.5.tar.gz 
    2525}}} 
    26 If you are using an instance of R installed in the system (ie, as root), you need to get root privileges to perform the rotRPackage installation or to install it in a non-standard location. Check your path to know which instance your are using. This instance '''must''' be the one you will pass to the configure script. 
     26If you are using an instance of R installed in the system (ie, as root), you need to get root privileges to perform the rot installation or to install it in a non-standard location. Check your path to know which instance your are using. This instance '''must''' be the one you will pass to the configure script. 
    2727 
    2828If you don't have the privileges to perform the installation with the previous command, use this one: 
    2929{{{ 
    30 R CMD INSTALL --library=PRIVATE_DIRECTORY utils/rotRPackage_1.4.3.tar.gz 
     30R CMD INSTALL --library=PRIVATE_DIRECTORY utils/rot_1.4.5.tar.gz 
    3131}}} 
    3232where PRIVATE_DIRECTORY is any directory you are allowed to write in (for example, $HOME/Rpackages). Then, set the environment variable R_LIBS to this directory (e.g. export R_LIBS=$HOME/Rpackages) if you use a version of R prior to 2.5.0, else it is better to use the environment variable R_LIBS_USER. 
     
    4040Type 'q()' to quit R. 
    4141 
    42 > library(rotRPackage) 
     42> library(rot) 
    4343> 
    4444}}} 
     
    4646 
    4747We can also see which version is installed by using the "sessionInfo" function.  
    48 In the following session, we see that rotRPackage_1.4.4 is used. 
     48In the following session, we see that rot_1.4.5 is used. 
    4949 
    5050{{{ 
    5151> sessionInfo() 
    52 R version 2.11.1 (2010-05-31)  
    53 x86_64-pc-linux-gnu  
     52R version 2.14.1 (2011-12-22) 
     53Platform: x86_64-pc-linux-gnu (64-bit) 
    5454 
    5555locale: 
    5656 [1] LC_CTYPE=fr_FR.UTF-8       LC_NUMERIC=C               
    5757 [3] LC_TIME=fr_FR.UTF-8        LC_COLLATE=fr_FR.UTF-8     
    58  [5] LC_MONETARY=C              LC_MESSAGES=fr_FR.UTF-8    
    59  [7] LC_PAPER=fr_FR.UTF-8       LC_NAME=C                  
     58 [5] LC_MONETARY=fr_FR.UTF-8    LC_MESSAGES=fr_FR.UTF-8    
     59 [7] LC_PAPER=C                 LC_NAME=C                  
    6060 [9] LC_ADDRESS=C               LC_TELEPHONE=C             
    6161[11] LC_MEASUREMENT=fr_FR.UTF-8 LC_IDENTIFICATION=C        
     
    6565 
    6666other attached packages: 
    67 [1] rotRPackage_1.4.4 
    68  
    69 loaded via a namespace (and not attached): 
    70 [1] tools_2.11.1 
     67[1] rot_1.4.4 
    7168}}} 
    7269