wiki:FAQ

Version 4 (modified by regis.lebrun@…, 12 years ago) (diff)

Explain how to install and use rotRPAckage in a non-standard location

Frequently Asked Questions about Open TURNS

Troubleshooting

Build & install process failure

Failures during the 'make' stage - KernelSmoothing.cxx compilation error

You may encounter failures during the compilation of KernelSmoothing.cxx around line 86 :

KernelSmoothing.cxx:86: error: type specifier omitted for parameter `bandwidth'

This bug is due to the poor parsing capability of gcc 3.3.5 and below, when compiling Open TURNS version 0.10.0 and below. You may either upgrade gcc to 3.3.6 (or higher) or upgrade Open TURNS to 0.11.0 (or higher).


Failures during the 'make check' stage

You probably forgot to install rotRPackage as described in the HowToInstall? page. Please install it.

R CMD INSTALL utils/rotRPackage_1.4.3.tar.gz

If you are using an instance of R installed in the system (ie, as root), you need to get root privileges to perform the rotRPackage installation or to install it in a non-standard location. Check your path to know which instance your are using. This instance must be the one you will pass to the configure script.
If you don't have the privileges to perform the installation with the preceeding command, use this one:

R CMD INSTALL --library=PRIVATE_DIRECTORY utils/rotRPackage_1.4.3.tar.gz

where PRIVATE_DIRECTORY is any directory you are allowed to write in (for example, $HOME/Rpackages). Then, set the environment variable R_LIBS to this directory (e.g. export R_LIBS=$HOME/Rpackages) if you use a version of R prior to 2.5.0, else it is better to use the environment variable R_LIBS_USER.
You can then test the installation by invoking R, then trying the following command:

$ R

R : Copyright 2006, The R Foundation for Statistical Computing
[...skip...]
Type 'q()' to quit R.

> library(rotRPackage)
>

If everything is ok, the command is executed without any error or warning.


Failures during the 'make check' or 'make installcheck' stage

Your installation of R cannot find gs, the ghostscript interpret. It is a problem related to the packaging of R, you can fix it by installing gs.